View Issue Details

IDProjectCategoryView StatusLast Update
0002215VPOP3Miscpublic2021-08-18 17:10
ReporterpaulAssigned Topaul 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionnot fixable 
Product Version8.2 
Target Version8.3Fixed in Version 
Summary0002215: Incoming SMTP mail to distribution list that shouldn't be accessible from the Internet is still being delivered
Description.
TagsNo tags attached.
Support Ticket NumberBWS-DPCTS-850
Time Estimate

Relationships

related to 0002216 new Have option to turn off Mappings overriding 'do not allow remote access to list' option 
related to 0002217 resolvedpaul Add 'SMTP Incoming' and 'SMTP Local' Mapping types 

Activities

paul

2021-08-18 11:19

administrator   ~0000830

This is not a bug. There was a Mapping to the list, so the Mapping overrode the 'do not allow remote access to the list' setting.

That is 'by design', but I'm not sure the design is right. It's there to allow remote access to groups etc, but 'do not allow remote access' is an explicit setting.

The problem is that if you have multi-domain setup, then Mappings are needed, and if you have to use an "SMTP Mapping" to let local users access the list, but then that also affects incoming SMTP, so there's no way around this except by using SMTP rules or similar to filter it.

Maybe have an option to stop Mappings overriding 'do not allow remote access'. I'm not sure if this should be default or not. For backwards compatibility it should not be, but it seems more logical that it should be.

Issue History

Date Modified Username Field Change
2021-08-17 13:30 paul New Issue
2021-08-17 13:30 paul Status new => assigned
2021-08-17 13:30 paul Assigned To => paul
2021-08-18 11:19 paul Status assigned => closed
2021-08-18 11:19 paul Resolution open => not fixable
2021-08-18 11:19 paul Note Added: 0000830
2021-08-18 11:20 paul Relationship added related to 0002216
2021-08-18 17:10 paul Relationship added related to 0002217