View Issue Details

IDProjectCategoryView StatusLast Update
0002136VPOP3SMTP Clientpublic2020-04-02 14:20
ReporterpaulAssigned Topaul 
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Version7.10 
Target Version7.11Fixed in Version7.11 
Summary0002136: SMTP MX DNS Overrides can't handle : in username or @ in password
Description.
TagsNo tags attached.
Support Ticket NumberRVN-WBWVZ-054
Time Estimate

Activities

paul

2020-04-02 14:20

administrator   ~0000818

Last edited: 2020-04-02 14:20

View 2 revisions

@ are allowed in passwords now using normal URLs (because a @ in a server name is invalid, so there's no ambiguity there)

For more complex usernames/passwords you can use quoted strings

eg

"my\@user\"name\:with\:colon:my\@password\:with\\colon@server:587"

Use \ to quote @, \, :, " inside username or password (but not @ and : as separators)

Issue History

Date Modified Username Field Change
2020-04-02 11:56 paul New Issue
2020-04-02 11:56 paul Status new => assigned
2020-04-02 11:56 paul Assigned To => paul
2020-04-02 14:20 paul Status assigned => resolved
2020-04-02 14:20 paul Resolution open => fixed
2020-04-02 14:20 paul Fixed in Version => 7.11
2020-04-02 14:20 paul Note Added: 0000818
2020-04-02 14:20 paul Note Edited: 0000818 View Revisions